Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   STO on Samsung R505 (ATI 3470, 256 MB RAM) (http://sto-forum.perfectworld.com/showthread.php?t=56195)

Archived Post 01-12-2010 01:33 AM

STO on Samsung R505 (ATI 3470, 256 MB RAM)
 
Hello

I use a Samsung R505 Laptop. The most games working very well , like Assansis Creed, FS X, Eve Online etc.

When I start STO only a black screen appears with a version information at the bottom and the STO theme is played.

I realize that i can't expected the performance of a Desktop Computer but at least the trailer should run.

Any Ideas?

Hardware:

AMD X2 2.0 GHz
ATI HD3470x with 256 MB real RAM (not shared)
3 GB RAM
Windows 7 Ultimate 64bit

Archived Post 01-12-2010 01:40 AM

Have you updated your drivers? That warning about out of date drivers is really quite serious. Even if you don't get a warning, get the most recent WHQL-signed drivers from ati.com and then try again. Doing so fixed the issue for me.

Archived Post 01-12-2010 01:44 AM

If the driver update alone doesnt fix your issue, try setting your desktop resolution as low as you can.(ie. 800x600x16)
Then fire up STO and see what happens. Laptop gfx systems are evil hacks that plague all programmers.

Archived Post 01-12-2010 02:23 AM

SOLVED STO on Samsung R505 (ATI 3470, 256 MB RAM)
 
Thanks to SpaceDrake and DaWookie.

I had forgotten to install the ATI drivers, so i used the default MS drivers since my last installtion a few days ago. :)

The game starts now.

For other Users of a Notebook with the Mobility HD Series, download the ATI Betadrivers on:

ATI Beta Driver Download

cu
Alexopolis


All times are GMT -7. The time now is 10:05 AM.