Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Zen Store Issues (http://sto-forum.perfectworld.com/showthread.php?t=591181)

xaviermace86 03-21-2013 07:10 PM

Zen Store Issues
 
I've submitted two support tickets on this, neither of which has gotten any response. When I open the Zen Store or view my account here on the website, it currently shows 0 Zen which is incorrect. In addition, when I try to claim any of the Zen items I've purchased over the last 3 years (Say the DS9 bundle or the Collectors/Deluxe Edition items), it tells me "Unable to complete transaction: You do not have enough Zen". Lastly my Zen history here on the website is completely empty which is sadly, horribly incorrect. Can anybody assist me please?

Edit: Just for giggles, I logged into Tribble with the same account. Zen works fine there.
Edit 2: I just purchased 500 more Zen. Purchase went through, shows my balance as 500 Zen. Still can't claim any previously purchased items nor can I purchase anything with that 500 Zen.

grouchyotaku 03-21-2013 09:33 PM

So are you going to tell everyone what items you're having trouble claiming? (As this is a Peer to Peer support forum...)

Or did you actually intend to have posted this in the 'Zen & Billing' section of the PWE Tech support forum, located here... http://techsupport.perfectworld.com/

xaviermace86 03-22-2013 05:47 PM

Quote:

Originally Posted by grouchyotaku (Post 8738411)
So are you going to tell everyone what items you're having trouble claiming? (As this is a Peer to Peer support forum...)

Or did you actually intend to have posted this in the 'Zen & Billing' section of the PWE Tech support forum, located here... http://techsupport.perfectworld.com/

I provided two examples. I'm not sure what providing a complete list of every Zen item I purchased would change. Let's just go with "all of it". PWE/Cryptic finally responded to one of my tickets stating they think they fixed the issue, I'll see if that's the case this weekend.


All times are GMT -7. The time now is 03:16 AM.