Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   STO running on low end hardware (http://sto-forum.perfectworld.com/showthread.php?t=60690)

Archived Post 01-13-2010 07:09 PM

STO running on low end hardware
 
K, I'm at work and have a little bit of spare time. I copied the STO client into my 16gb thumbdrive and hooked that up on my office Dell Vostro V13 laptop. Guess what, it's playable! I participated in a Starbase 24 fight briefly then beamed into the station for some ground combat. It's still playable! I'm gonna try tweak the gfx settings for better playability. Any guides around?

Amazing.

My Vostro V13 spec;

C2D SU7300 1.3Ghz CULV
2GB DDR3
500GB Seagate HDD
Intel 4500MHD integrated graphics running at 1366x768 res.
Windows 7 Basic (yeah, special version for Asia).

STO ran off a 16gb Kingston thumbdrive.

Archived Post 01-13-2010 07:25 PM

Cool trick. Star Trek Online in my pocket wherever I go. Yeah could get used to that. :D

Archived Post 01-13-2010 07:25 PM

The game is working just fine for me:

P4 3.2 (yes, single core)
3 gigs memory DDR266
ATI 3850 AGP 512mb
Win XP.

Can use med-high graphics settings and frame rates are just fine.

Archived Post 01-14-2010 05:37 AM

Yep, same here. For the heck of it I thought I would see if it would run on my Dell optiplex 745. It's a P4 D series processor, 1 gig memory, and some generic motherboard intel video card.

It's a little choppy, steering the character with the keyboard is kind of a chore but it is working.


All times are GMT -7. The time now is 08:31 AM.