Star Trek Online

Star Trek Online (
-   Gameplay Bug Reports (
-   -   Cannot fire wepons bug. (

Archived Post 01-13-2010 09:27 PM

Cannot fire wepons bug.
Ive had this happen to me 2 times since beta started. Ill be fighting a enemy ship and no weapons will fire. I don't really know what else to add to this other than it seems pretty rare and I was in a instance alone.
However everything else seems to work like equalization of shields and other special non attacking moves.

I have also reported this in game.

Archived Post 01-13-2010 09:57 PM

Are you sure the enemy ship is in your firing arc? tis was happening to me then I relaised the the weapon wont fire if the ship is outside it's firing arc.

Archived Post 01-13-2010 10:10 PM

i've had an issue with having more than one type of weapon in the same areas having that happen

for example, having two fore torpedoes or two forward arrays i can only activate one, the second seems to lock out

Archived Post 01-13-2010 10:10 PM

Both times this happened I had multiple NPC's attacking me I tryed targeting different ships still the ship wouldn't fire. The last time this happened I ran away for around 5 minutes while filling out a bug report and when I was finished I could fire again.

Archived Post 01-13-2010 10:13 PM

Only time I have seen this happen is when the rubberbanding lag started. No lag no problem firing weps.

Archived Post 01-13-2010 10:45 PM

I've had this with my torpedoes once. I was fighting an enemy ship and suddenly my torpedoes simply wouldn't fire anymore. Here's what I tried:

- Rotate the ship. Make sure the enemy is OUT of my firing arc, after which I move it back in to see if there's some kind of reset. No effect.

- Leaving combat. I set course away from the enemy at maximum speed so as to leave combat. The weapons did not reset so after re-entering combat my torpedoes still wouldn't fire.

- Smash the keys. No effect either :P

I relogged and that solved the issue. Maybe it was easier to leave the system and re-enter but I didn't try that so I can't say for sure if that solves the problem.

Archived Post 01-13-2010 10:54 PM

Yeah, i think this may be a lag issue. If it happens again, try the chat window to see if you are lagging or if it indeed is a weapons bug.

Archived Post 01-13-2010 11:53 PM

It is indeed a weapons bug.

I was flying with my friends yesterday and I had two torpedo launchers equipped in my forward slots.

I then recieved a torpedo launcher MK II from a dead battleship, I equipped it and for some reason I could only fire one of the two torpedo launchers.

Like someone else said in this topic, the other torpedo launcher seemed to be locked out, not clickable.

If I right clicked on the locked out torpedo launcher to set it as autofire it would indeed start firing but then the other torpedo launcher would become locked out.


Archived Post 01-14-2010 12:17 AM

I've found that alt-tabbing the application, in CO and STO both, completely neuters the action bar when you alt-tab back to the application.

One thing I've found that fixes this, if you're using the Steam download, is to hit shift+tab and enable the steam overlay then hit it again to disable it, then the UI works again.

I am unsure why this occurs. Previous to using the Steam overlay to jumpstart the game UI again, in CO and STO both I literally had to restart the client.

Accessing the bug interface may have been what did it for you, but it seems to be a universal bug in their XUI scripting.

All times are GMT -7. The time now is 06:00 AM.