Star Trek Online

Star Trek Online (
-   Gameplay Bug Reports (
-   -   Unable to submit ticket: Claims of profanity (

Archived Post 01-14-2010 11:39 AM

Unable to submit ticket: Claims of profanity
I try to submit a ticket about a glitch with upgrading BO's skills and it claims that i can't submit it due to use of profanity in my ticket. I don't use profanity and I've tried a couple times to submit it but the ticket just keeps claiming that I'm using profanity. Any help with this one?

Archived Post 01-14-2010 11:47 AM

In many cases one persons definition of a word does not match the actual definition of the word. You might have actually used profanity that you don't consider profanity. Post the actual text and we can at least work that part out.

Archived Post 01-14-2010 12:19 PM

Ill try to remember as best as I can so here goes nothin.
"When putting the first point into a skill of a BO, it does nothing, If I remove the point, the skill upgrades, but if I point the point back in, the skill downgrades. If I put a second point into the skill, the skill starts upgrading again. For example, Tachyon Beam has a recharge time of a min and 25 seconds. I upgrade it with a point and it stays there. I take the point out and the recharge time goes to a min and 20 seconds. I put the point back in and it goes up to a min and 25 seconds again. If I put another point in, it goes to a min and 20 seconds and continues to upgrade as it should from that point on"

Archived Post 01-14-2010 12:44 PM

I can't figure out any bad words, but I know it looks for certain patterns like "bars hit". It assumes you are trying to fool the filter by putting a space between the s and the h.

On another note, I've noticed this issue too... you put points in to things and cooldowns actually INCREASE in length... then you take points out and they decrease below what they were originally... weird stuff happening.

Take a look at what the points are actually doing to your abilities... not always improving them.

Archived Post 01-14-2010 01:21 PM

And the fact that the user may be submitting abuse complaints that contain profanity, this filter should NOT exist.

Archived Post 01-14-2010 01:27 PM


Originally Posted by Penetron
And the fact that the user may be submitting abuse complaints that contain profanity, this filter should NOT exist.

I agree. I don't think it was necessarily intentional for it to have a profanity filter.

You could post complaints about profanity that are carefully edited for the GM's virgin eyes.

Archived Post 01-14-2010 01:39 PM

It may be blocking it due to the words "put a" being right there. I know that it censored me in sector space zone chat when I mentioned it "didn't put a bridge officer where it should've been"... The only reason I can think of for that is that it's grabbing on to the Spanish (or was it Portugese?) word "p u t a" (spaces inserted so I don't get smacked on here by angry censors), a slang for "w h o r e". It seems like a rather dumb thing for them to censor, especially since there's a freaking space in there, but it's the only thing I can see in your post that might've tripped an automated alarm.


Archived Post 01-14-2010 02:10 PM

Sometimes I'm lazy, or just in a rush. instead of typing who're i type who re (using a space to indicate a contraction instead of an apostrophe). This got filtered and came up )(*)(. I've seen this happen before too in other chat clients where the filter is a little too strict. So you guys might be onto something with the "bars hit" and "put a". That brings me to a thought. Have you guys tried putting an apos. in between words like put a and bars hit (bars' hit or put' a) to see if it would work around it? I know this is silly and we shouldn't have to do this but at least you'd be able to report your bug issue until they make the filter a bit more sensible.

All times are GMT -7. The time now is 11:36 AM.