Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   I don't know what to do now (http://sto-forum.perfectworld.com/showthread.php?t=64457)

Archived Post 01-15-2010 05:18 PM

I don't know what to do now
 
I'm at Vega Colony. It says pick up a phaser rifle and get a kit from the Ensign. I picked up the phaser rifle, but accidentally discarded it while trying to equip it. I talked to the Ensign to get a kit, she didn't give me anything. My quest list still says to get a phaser rifle and a kit, but the phaser rifle has vanished and the Ensign won't speak to me anymore. What should I do?

Archived Post 01-15-2010 05:20 PM

Abandon quest, redo :)

Archived Post 01-15-2010 05:20 PM

Try to restart the mission if you can. Reset the game, try to report it as a bug if nothing seems to be working. I had similar issues with other missions down the road, it can get really annoying after nearly completing a mission then being stopped by something like that, but it is a beta so it is to be expected.

Archived Post 01-15-2010 05:21 PM

If he discarded the rifle the quest wont work, thats not really a bug.

Archived Post 01-15-2010 05:21 PM

I've read this alot in the Zone Chat, try aborting the Mission and pick it back up again. (The Abort is on the mini map near Scan Area.)

Archived Post 01-15-2010 05:24 PM

Quote:

Originally Posted by Urko (Post 1451144)
If he discarded the rifle the quest wont work, thats not really a bug.

True, but as it is one of the first few ground missions it could help if the NPC recognized you don't have the rifle in your inventory then re-issue it if needed.

Archived Post 01-15-2010 08:05 PM

Quote:

Originally Posted by Urko (Post 1451144)
If he discarded the rifle the quest wont work, thats not really a bug.

That's true. I made a mistake with that. But the kit problem was a bug. The Ensign was supposed to give me a kit. She said she was going to, but she didn't. It was kinda silly.

Archived Post 01-15-2010 08:08 PM

There've been big problems with this mission. I couldn't get the damned rifle for about an hour and I was surrounded by hundreds of people hitting the f key on one of the crates with the same frustration lol. Just a bit of a buggy mission at the moment methinks.

The bug you have seems to stem from the ease with which you can lose the rifle through the UI. I've read this once or twice on other posts but I didn't have that problem myself. Aborting seems to be your only option...

Archived Post 01-16-2010 02:54 AM

I'm stuck in this exact situation. Unfortunately it seems I can't drop the Assimilation mission.

Does this mean I have to start a whole new character and go through the tutorial again?

If that's my first impression of this game, it's leaving a bad taste. I just want to fight space ships :(

Archived Post 01-16-2010 06:46 AM

Quote:

Originally Posted by WittyDroog (Post 1460264)
I'm stuck in this exact situation. Unfortunately it seems I can't drop the Assimilation mission.

Does this mean I have to start a whole new character and go through the tutorial again?

If that's my first impression of this game, it's leaving a bad taste. I just want to fight space ships :(

It's the beta though man, so there's a whole host of issues they'll be fixing as well as this one. Let the final version be the one that makes an impression.

I've had the same problem for days now. I picked up the rifle, accidentally dropped it, but was never given a kit either way. It's just the sheer weight being put on the servers I think. I can't seem to drop the "Assimilation" quest either so I'm kinda screwed. I think I'll just have to roll this toon again and hope that THIS time it'll work.

Like I said though, it's the beta so I'm willing to let this slide.

This game really looks like it has great potential!


All times are GMT -7. The time now is 05:02 AM.