Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Zoning/Map loading (http://sto-forum.perfectworld.com/showthread.php?t=72016)

Archived Post 01-19-2010 05:21 PM

Zoning/Map loading
 
Ok... this is not new, I suppose, but I'm going to put this out there for the frustration level...

I have been unable to play for the last three days. I have tried several times but, I have been either hit with the nearly endless "Server Busy" problem or, when I do get lucky enough to get passed that, I'm either greeted by the endless "Retrieving Map List" message (as of writing this, I've been waiting over ten minutes to see if it goes away and loads a map), or I load the map only to "drift" (no control, no engine output but I just sort of slowly drift) without end. Just for reference, I live in the EST time zone.

For three days this has been my experience with STO. At this rate I just might be able to play the game all of five minutes before the game goes live! *sighs* I know this is open beta. I'm NOT planning on canceling my pre-order, I think this game has some massively fun potential. But, damn this is annoying!

May I make a suggestion? Next time you develop a game, DO NOT design your servers expecting only 65% of your keys be to used. Design your servers to expect 100% of them to be used. Why? Don't you hate it when ******* at the Airlines over book flights? Well... this is the same thing.


All times are GMT -7. The time now is 01:54 AM.