Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Graphical and Sound Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=148)
-   -   Character loading screen issues (http://sto-forum.perfectworld.com/showthread.php?t=751631)

captfabulous 06-14-2013 02:31 PM

Character loading screen issues
 
As can be seen in the picture, parts of boffs are missing, and it always shows the equipped shuttle instead of starship.

If you click another character and then go back everything then seems to load correctly and show the correct ship, but rarely ever on the first try.

http://i.imgur.com/NR8kHoT.jpg

drake122svk 06-22-2013 02:04 PM

I have the same issue with the Jem'Hadar BOFF and Romulan Male BOFF's hair is also missing. Annoying but hardly an issue for anyone.

overlapo 06-22-2013 05:47 PM

It happens with the borg you get from the STF too.

aleaic 06-24-2013 07:28 PM

My Borg has this problem too. Been that way since expac launch.

hylanvahr 06-27-2013 12:45 PM

Quote:

Originally Posted by captfabulous (Post 10842551)
As can be seen in the picture, parts of boffs are missing, and it always shows the equipped shuttle instead of starship.

If you click another character and then go back everything then seems to load correctly and show the correct ship, but rarely ever on the first try.

http://i.imgur.com/NR8kHoT.jpg

This has been a bug that has been present in the game for almost a year since Season 6, long before we could see our full bridge crews and ships on the character select screen. It's a result of the UI change that allows you to ready both a starship and shuttle at the same time from a shipyard.

When you beam up into space, the code is written to make the game load your shuttle and then your ship. You aren't supposed to see your shuttle appear, but I have seen this happen to me more than a few times since S6. For some reason, this glitch fails to load beyond your shuttle up to your ship. For now, you have to select another character then back to the gitched one for it to show your ship.

This glitch also breaks character info database retrieval when you click on other players in space or on the ground and click on "i" info button next to their portrait. 9 times out of 10 you'll see a mostly blank info window, or it will show the name and class of a shuttle they have ready even if they are clearly piloting their starship.

Season 6 was a heavily buggy addition to STO, but it's simply not profitable for Cryptic to go back through the layers and fix it. Expect this shameful bug to persist for a longtime to come.


All times are GMT -7. The time now is 12:13 AM.