Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Graphical and Sound Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=148)
-   -   Ship Tailor Color Alteration Broken (http://sto-forum.perfectworld.com/showthread.php?t=769501)

warmaker001b 06-27-2013 11:29 PM

Ship Tailor Color Alteration Broken
 
The Ship Tailor option to alter colors for your starship or shuttle is broken. You can still change skins and patterns, but fiddling with the colors does absolutely nothing.

drowrulesupreme 06-28-2013 12:32 AM

You did use the ADVANCED tab to alter the colour PATTERNS first, right? Otherwise you are changing colours on no pattern. You can have each ship part a different pattern to suit.
I go for Corvus mostly, but Gemini on my Romulans.

blackjackwidow 06-28-2013 03:45 AM

Quote:

Originally Posted by warmaker001b (Post 11092961)
The Ship Tailor option to alter colors for your starship or shuttle is broken. You can still change skins and patterns, but fiddling with the colors does absolutely nothing.

I have this problem on my Romulan - have not tried on Fed or KDF since LoR. Was this on a Rom?

The color doesn't look like it's applied in the tailor, you can't see any preview. But, if you change the colors and purchase (free token) when you get out in sector space it has applied.

I have a couple of lower-level ships that are not at all to my liking because I couldn't preview the change. Plus the color in the selector looks much lighter than the color once it's on a ship. This happened every time I've used the flotilla/RR ship tailor. I plan to try the ESD/Q'onos ship tailors, see if they work.

warmaker001b 06-29-2013 01:10 AM

Quote:

Originally Posted by drowrulesupreme (Post 11094161)
You did use the ADVANCED tab to alter the colour PATTERNS first, right? Otherwise you are changing colours on no pattern. You can have each ship part a different pattern to suit.
I go for Corvus mostly, but Gemini on my Romulans.

Of course I used the Advanced tab. That's how I was able to still change the skins and patterns. But again, color remains the same, no matter what I pick from the palette.

Quote:

Originally Posted by blackjackwidow (Post 11096461)
I have this problem on my Romulan - have not tried on Fed or KDF since LoR. Was this on a Rom?

The color doesn't look like it's applied in the tailor, you can't see any preview. But, if you change the colors and purchase (free token) when you get out in sector space it has applied.

I have a couple of lower-level ships that are not at all to my liking because I couldn't preview the change. Plus the color in the selector looks much lighter than the color once it's on a ship. This happened every time I've used the flotilla/RR ship tailor. I plan to try the ESD/Q'onos ship tailors, see if they work.

I first noticed this problem with my Alien toon with the KDF.

jackson900pwe 07-01-2013 03:00 PM

Don't worry you ain't alone. I got this cappy problem, too. It's getting on my damn nerves as well. Cryptic this and ALL bugs need to be fixed ASAP no excuses.

lomax6996 07-07-2013 08:00 PM

Yep. I have that problem. On my Rom if I choose a pattern often the color is so washed out you can't even tell it's there. I find that if I fiddle with the various settings (skins, basic patterns, etc.) eventually it kicks in. However all the colors show on the ship as a kind of dark reddish brown, regardless of the color chosen on the palette. Have seen this some on KDF since LoR release but mostly on Rom character. Both ship and the character tailor are all messed up. Seriously needs a major fix, Cryptic!! :(

northwardbound 07-08-2013 05:56 PM

when the Risian Corvette becomes availabe to most of the gaming population, there will be such an outcry about not being able to adjust the color that they will finally prioritize this. Until then, tough titty

futurepastnow 07-08-2013 09:57 PM

The workaround is to select a stock ship template on the left, edit the colors as desired, then go into Advanced and change the individual ship parts to the ones you want.

northwardbound 07-08-2013 10:32 PM

Quote:

Originally Posted by futurepastnow (Post 11297321)
The workaround is to select a stock ship template on the left, edit the colors as desired, then go into Advanced and change the individual ship parts to the ones you want.

I can comfirm this to anyone else reading this. It does, however, present a flaw to those ships, like shuttlecraft, that do not have individual ship parts. For ships like those, it is black or nothing.

saurializard 07-09-2013 03:37 PM

I'm not completely sure if it's part of the same problem, but loading a customized ship (one with mixed parts of the default models) can lead to the game loading one of the default versions and you need to load your model once (or more) again to have it finally load correctly. And of course, the colors will still be wrong.

Speaking of this, if your ship is a default one but with different patterns and colors, it'll load without any bug, even the colors will be correct.

EDIT: And... I just discovered even if you choose a default model, the material choice doesn't work at all for Romulan ships (at least the Ha'apax). The randomize option, however can switch between materials.

EDIT: And Type 1 windows for Romulan ships lack their textures, instead appearing as big purple squares.


All times are GMT -7. The time now is 10:44 AM.