Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   Launcher Autoupdate not connecting (http://sto-forum.perfectworld.com/showthread.php?t=771531)

scister 06-29-2013 06:05 AM

Launcher Autoupdate not connecting
 
Hi,

Since the last patch I have had numerous issues with getting the game to load. At first I could hit engage on the patcher but the game would freeze on the 'Cryptic' screen.

So I uninstalled the game and re-installed (on both Steam and from the STO website) and now the launcher won't open. I get a popup saying 'Unable to establish connection to Patch Server'.


Any suggestions?


Thanks

deutchcraft 06-29-2013 07:43 AM

I have the exact same problem. Its driving me nuts

azngal8907 06-29-2013 02:15 PM

Unable to connect to Patch Server
 
Having the same problem. I have re-installed the game on my primary playing computer and still no go. Still states that it is unable to connect to Patch Server check internet connection. I tried installing the game on to other computers I have and still the same message pops up. I have already contacted Tech Support and they did not help at all. Told me to do the same things that I have already tried.

Very frustrated right now and for sure others that are having the same problem are as well.

captainleavitt 06-29-2013 04:17 PM

same problem here. i'm really annoyed right now.

scister 06-30-2013 02:35 AM

Hi Guys,

After checking other threads on similar subjects I found out it was my firewall. I just temporarily disabled it and am now patching the game. Give it a go.


All times are GMT -7. The time now is 06:17 PM.