Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Star Trek Online General Discussion (http://sto-forum.perfectworld.com/forumdisplay.php?f=128)
-   -   Grrrr...waiting 24 hours for my BORG is not acceptable (http://sto-forum.perfectworld.com/showthread.php?t=88909)

Archived Post 01-29-2010 02:53 PM

Grrrr...waiting 24 hours for my BORG is not acceptable
 
Fix This Now

Archived Post 01-29-2010 02:54 PM

fixed, but i have to mail you the fix which will take two weeks.

Archived Post 01-29-2010 02:54 PM

Borg creation is available now. Just visit the C-store in-game on an existing character to claim it.

Archived Post 01-29-2010 02:55 PM

Quote:

Originally Posted by Rekhan
Borg creation is available now. Just visit the C-store in-game on an existing character to claim it.

I just checked there nothing, logged out and in still nothing.

Archived Post 01-29-2010 02:55 PM

Quote:

Originally Posted by Rekhan
Borg creation is available now. Just visit the C-store in-game on an existing character to claim it.

Not working for me.

Archived Post 01-29-2010 02:56 PM

Quote:

Originally Posted by Rekhan
Borg creation is available now. Just visit the C-store in-game on an existing character to claim it.

Wrong, perhaps you should check with the techs before making this claim. For me and many others it is neither in the C-store of available at login.

Archived Post 01-29-2010 02:56 PM

did you try relogging onto the game?

Archived Post 01-29-2010 02:56 PM

Quote:

Originally Posted by Rekhan
Borg creation is available now. Just visit the C-store in-game on an existing character to claim it.

Just tried and this is STILL not working.

Archived Post 01-29-2010 02:57 PM

Quote:

Originally Posted by Rekhan
Borg creation is available now. Just visit the C-store in-game on an existing character to claim it.

Its clearly not working and its been stated elsewhere by crypic employees that the c-store is no longer required.

The miss information flying around is just beyond incredible really. I really dont know how else to respond to this but I expect you will continue locking more threads that dont please you. Your quite good at that it appears.

Archived Post 01-29-2010 02:57 PM

Not working. Honestly. Over 24 hours since I got the lifer, have tried relogging. HAve checked the C-store. Not there, I swear.


All times are GMT -7. The time now is 07:44 AM.