Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Star Trek Online General Discussion (http://sto-forum.perfectworld.com/forumdisplay.php?f=128)
-   -   Borg still broke, contrary to Cryptic's claim (http://sto-forum.perfectworld.com/showthread.php?t=88994)

Archived Post 01-29-2010 03:35 PM

Borg still broke, contrary to Cryptic's claim
 
I keep seeing people claim the Borg are working but log intot he game, the in-game chat is riddled with
people that are experiencing the same issue, the Borg not working.

Archived Post 01-29-2010 03:40 PM

Bump....keeping this in plain view.

Archived Post 01-29-2010 03:42 PM

my borg captain disagrees....

Archived Post 01-29-2010 03:42 PM

http://forums.startrekonline.com/showthread.php?t=88909

http://forums.startrekonline.com/showthread.php?t=88470

http://forums.startrekonline.com/showthread.php?t=88502

http://forums.startrekonline.com/showthread.php?t=88809

Archived Post 01-29-2010 03:44 PM

I got my sub this morning, Ticket: #552517 Please help I just want to play and not be left behind by my group of 5 friends who are waiting for me....without having to just restart when borg activates anyways


I will be posting on every thread about this till I am noticed :(

Archived Post 01-29-2010 03:45 PM

http://forums.startrekonline.com/showthread.php?t=89015

They are asking you to post this issue here. Their is a link on the main page that talks about this issue.


All times are GMT -7. The time now is 01:41 PM.