Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   The Academy (http://sto-forum.perfectworld.com/forumdisplay.php?f=127)
-   -   Graphics card (http://sto-forum.perfectworld.com/showthread.php?t=89573)

Archived Post 01-29-2010 11:05 PM

Graphics card
 
Does anyone know if this game will play on an Intel 945GM Express graphics card? I don't want to pay for the game if it won't play.

Archived Post 01-30-2010 01:22 AM

Quote:

Originally Posted by Atergo
Does anyone know if this game will play on an Intel 945GM Express graphics card? I don't want to pay for the game if it won't play.

I tried it on my netbook during open beta. Keep in mind that my netbook only has an Atom processor and 1GB of RAM... You can sort of play if you don't mind dying a lot. I found it a very frustrating experience.

If you can, get a better graphics card. Even something you can find for $40 will be better than the 945GM

Archived Post 01-30-2010 02:36 PM

Currently it would seem that a NVIDIA card is the best choice, at least for now. im using ATI and the crash bugs are becoming intolerable. Any other ATI ppls suffering too???

Archived Post 01-30-2010 02:38 PM

I've been playing it on a (very) old GeForce 6200 since my 8800 burnt out. Very low settings but still playable

Archived Post 01-30-2010 02:41 PM

try this website....always helps me :)

game requirements lab

Archived Post 01-30-2010 02:41 PM

I play on an Intel 965 express on a laptop and i have no problems

Archived Post 01-30-2010 03:00 PM

ati
 
Quote:

Originally Posted by DJLeeZ (Post 1790945)
Currently it would seem that a NVIDIA card is the best choice, at least for now. im using ATI and the crash bugs are becoming intolerable. Any other ATI ppls suffering too???

YES! Me too, and I just got mine. Radeon HD 4650 :(

Archived Post 01-30-2010 03:18 PM

Quote:

Originally Posted by DJLeeZ (Post 1790945)
Currently it would seem that a NVIDIA card is the best choice, at least for now. im using ATI and the crash bugs are becoming intolerable. Any other ATI ppls suffering too???

I've been running a Radeon HD5870 since Open Beta with no problems. I've only crashed once, while going through the SS Azura, and I don't know what to attribute that to. Server disconnects have been the only regular problem I've had. This is running on Windows 7 with Catalyst 9.11 drivers.


All times are GMT -7. The time now is 02:13 PM.