Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Graphical and Sound Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=148)
-   -   Bad gameplay quality. Help! (http://sto-forum.perfectworld.com/showthread.php?t=90197)

Archived Post 01-30-2010 09:11 AM

Bad gameplay quality. Help!
 
I have been watching gameplay videos and screen shots of STO and the quality is much better than what I am playing on my computer. The graphics aren't smooth or anything. I feel as if it is a game made five years ago. Maybe it is my graphics card or something about my computer. I just bought it 6 months ago. Here are my specs. Please help. I want to enjoy the game

Processor: AMD Athlon 7550 Dual Core Processor 2.5 GHz
8GB ram
Windows 7 Home Premium
64-bit operating system
Video Card: NVIDIA GeForce 9100

Archived Post 01-30-2010 12:08 PM

Are you sure you're using the GeForce 9100? That seems to be a mobile GPU (that or it's integrated on your motherboard), and it's a low end one at that. It's borderline adequate for the game, and you're probably needing to run at low resolutions and detail settings to get smooth framerates.

A video card upgrade would do wonders for you, because aside from the GPU your system is pretty good for gaming.

Archived Post 01-30-2010 12:46 PM

Are you serious 8gb isnt needed vor a gaming pc and a phenom 2 x3 or x4 is away bettter. But when you want better graphic you need a better graphic card, ala 5770 as example

Archived Post 01-30-2010 11:15 PM

Thanks. I upgraded my graphics card to a 9800. Everything looks great now. Thanks for all your info.


All times are GMT -7. The time now is 03:00 PM.