Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Star Trek Online General Discussion (http://sto-forum.perfectworld.com/forumdisplay.php?f=128)
-   -   Long load screens? (http://sto-forum.perfectworld.com/showthread.php?t=90331)

Archived Post 01-30-2010 10:55 AM

Long load screens?
 
anyone else see LOOONG load screens since last nights patch?

Archived Post 01-30-2010 10:57 AM

Nope mine only takes about 5-8 seconds to load

Archived Post 01-30-2010 10:57 AM

Now, it takes 2-3 minutes if I change the system. That botheres me.

Archived Post 01-30-2010 10:58 AM

Yeah, good to know it's not just me, I guess.

Archived Post 01-30-2010 11:00 AM

Yeah the loading time right now is horrendous for me.

Archived Post 01-30-2010 11:06 AM

Stuck in a load screen right now, it's been 3+ mins.

Archived Post 01-30-2010 11:07 AM

Yeah... so much for fixing server stability. It has been taking MUCH longer on loading screens and sometimes after I finish away missions i beam up and it still shows me on the planet.

I logged off to try and fix this problem and now I am stuck at the "Retrieving character list" screen.

Archived Post 01-30-2010 11:07 AM

Yup it's getting worse.

Fully expect 2-3 hour maintenance coming up soon... good time for a shower and some lunch.

Archived Post 01-30-2010 12:35 PM

Quote:

Originally Posted by DagnyTaggart
Yup it's getting worse.

Fully expect 2-3 hour maintenance coming up soon... good time for a shower and some lunch.

Heh, you called that pretty good, Dagny. :)

Archived Post 01-30-2010 01:13 PM

Yeah I wasn't sure what what up with that. Literally it got noticeably worse each time, finally had enough of it once it got over 5 minutes per map, and decided to log for a bit, looks like I picked a good time and place to stop LOL.


All times are GMT -7. The time now is 11:14 PM.