Star Trek Online

Star Trek Online (
-   Mac: PC, Network, and Other Technical Issues (
-   -   Mac STO client fails to go to main menu (

cogitation1 11-13-2013 09:18 PM

Mac STO client fails to go to main menu
I wasn't able to find a troubleshooting page. If somone could provide a link, I would appreciate it, thanks.

Here's what I've done and seen, so far:

1) I downloaded the Launcher.
2) I ran the Launcher.
3) I logged into the Launcher. This caused the Launcher to download the client.
4) At least once, the Launcher would unexpectedly quit. On each such instance, starting the Launcher again would cause a dialog box to appear for a split second, disappear, and quit the Launcher. Starting the Launcher yet again opens the normal Launcher window, and logging in resumes the download.
5) Once the download is complete, I would click ENGAGE.
6) My monitor resizes from it's normal 2560*1440 to 1280*960. (Yes, this switches the aspect ratio from 16:9 to 16:12.)
7) The screen goes mostly black, except for the white CRYPTIC logo in the middle of the screen and a gray loading bar at the bottom that slowly fills with white.
8) When the loading bar fills, the screen goes to black. A medium-sized rectangle flashes once in the upper-left corner of the screen (I'm eyeballing it at maybe 300*300 pixels), and then the monitor resizes back to 2560*1440 and shows me my normal Finder desktop, as though the application has quit. However, 3 or 4 "Star Trek Online"s would apper in the Command-Tab listing of applications to switch to. I can't get to any STO interfaces by Command-Tabbing to any of those instances.

Has anyone else been seeing this? Is there an error log anywhere that I can look for?

amedees 12-09-2013 04:28 PM

I've been getting the same thing on my MacBook Pro. The app just quits with no message

amedees 12-12-2013 06:54 AM

I've also tried erasing and reinstalling the game. Still won't run on my MacBook ProR

amedees 02-15-2014 06:14 AM

Does anyone else have this problem? Even after the current patches I can't launch STO on my MacBook Pro Retina. I just get past the Cryptic Loading screen then returns me to the desktop.

All times are GMT -7. The time now is 11:39 AM.