Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Graphical and Sound Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=148)
-   -   Chaacter select screen is entirely black (http://sto-forum.perfectworld.com/showthread.php?t=933931)

xastirx 11-27-2013 12:39 AM

Chaacter select screen is entirely black
 
When i get past the legacy of romulus loading screen, and character select is going to appear, i hear the interface activate, and if i click in all the right places, for selecting a toon, or clicking a buton on he UI, i hear the buttons activate, but I have absoluetly NO VISUAL what so ever. Since i cant see what im doing in game to change between DX9 and DX11 im having to manually edit game files,which all that does is change the image quality of the loading screens that I can ACTUALLY see.

I have already tried completely purguing my PC of all STO related files and re downloading, and im still running into this problem.

kuznetsov101 11-27-2013 09:22 PM

you sir aren't alone. I too am having the same problems. Lets hope someone can help us out here.

xastirx 11-28-2013 09:43 AM

Nice to know i'm not alone on this one. Atleast it rules out that my video card can no longer handle STO. Though, now curiosity has me. my video card is a nVidia GeForce 8600M GS. What's yours? They say that these problems are video card related.

kuznetsov101 11-29-2013 06:02 PM

mine is an NVIDIA GeForce 9100. There should be no reason for it to be doing what its doing

xastirx 11-29-2013 08:02 PM

Indeed. Prior to this update, i was getting roughly 27 FPS in the dyson sphere. Only now my problem has escalated. now after the cryptic loading screen, the game crashes my computer tryiong to bring up the LoR loading screen, and mind you, this is after doing another uninstall, then manually removing and lingering taces of STO from my system and reinstalling.

rezking 11-30-2013 07:40 PM

I would get this same result if I try to run it normally.
I have visuals but no audio in compatability mode (xp sp3).

If I have to do an uninstall/reinstall, I'm going to contemplate whether or not I'll even bother with this game.

EDIT: I added "-ignorex64check" to the command line in the options menu...the audio came back but the game's fps was so bad it was unplayable.

xastirx 12-01-2013 01:30 PM

Is there a place where I can find a list of command lines that can be used? I want to know if there is one for setting it to use direct x 9 only. For some reason, the game tries to force using Direct X 9, Dect X 9ex, and directX 11 all simultaneously. this is causing the problem. And when i try to edit the game prefs file that has the error, it leads to a client crash, due to the fact that the game relies on each instruction being on its own line and yet all my word processors condense the text on a re-save of the file so that, for example the section that has the problem goes from looking like this:

IsDirectX9exEnabled 1
Is DirectX11Enabled 1

to this:

IsdirectX9exEnabled 1 IsDirectX11Enabled 1

Its suposed to look like the top of the two, but for somereason, even though the game allows for editing the file, it always converts to a condensed text format that consequently makes it unplayable to the game client.:(

The other thing I tried, since this always worked in the past was the equivalent of what one does when your ship has an iconian computer virus. Shut the game down, delete the affected files, and let STO restore itself from the Cryptic archives, but this only exaserbates the issue, since those setting information files seem to be stored THERE and so what I get are new copies of a bad command line.:mad:

And before anyone suggests updating my video driver, let me just say that the last time I did that, not only did STO never work on that system again, but I couldn't even run windows solitaire which proceeded to spit a message at me about an unrecognizable video card.:rolleyes:

EDIT: I also tried a reinstall using my collectors edition disc, but that install data goes all the way back to pre-season 1. guess what happened after that. the game repatched up to season 8 just as it should, but it also reupdated the game prefs file from default back to faulty.

xastirx 12-03-2013 08:14 PM

ok, so assuming that it is een possible to fix the glitch i got going, let me give you guys the rundown on what doesnt work.

Adjusting settings ingame to make it playable: Since everything is blacked out, including the UI I cannot see what I am clicking on.

Enabling all connected monitors since each screen might have a different resolution and one of them might support the faulty settings: My PC uses the same resolution for both my native monitor and my 32" HDTV. When I enabled all displays, it went froma blackout screen to a PC crash.

Command line in the launcher: Since the last time my launcher updated, I got a newer flashier UI that while it still has things for enabling/disabling, on demand patching or force verify, the command line text field is gone im afraid.

Reinstall STO from download or DVD: The game prefs file reasserts itself whenever STO tries to repatch to season 8.

Update video card drivers: Already tried this. Luckily I had the presence of mind to create a system restore point. After the latest nVidia driver made sto completely unlaunchable much less playable i again had the issue of not even being able to play solitaire. Yeah, nVidia's latest drivers cant even properly render an ace of spades...much less the other 51 cards in a standard poker deck.

Edit the gameprefs file: When I try that, one of two things happens. 1) The lines in the file get reformatted into one long unending line that STO can't use since each setting has to be its own line. 2) The game detects that the file that they have on record for my preferences for my PC and the file that is ON my PC don't match, thus it deletes and replaces those files so that they go back to their unuseable state.

So now that I have sufficiently conundrumed most of you guys, and stumped the rest, I leave you to attempt to solve this rather unique puzzle. I only say unique because my screen has been going black. most others are getting whited out, but still have the benefit of using the ingame GUI.

If anyone does come up with something I haven't tried yet, i'll attempt it if possible.

xastirx 12-03-2013 08:17 PM

Quote:

Originally Posted by kuznetsov101 (Post 13762751)
mine is an NVIDIA GeForce 9100. There should be no reason for it to be doing what its doing

Indeed. My video cards, all of them, are about the same level of sophistication and they're all acting up. the nVidia's and the ATI's.

rezking 12-03-2013 08:28 PM

Quote:

Originally Posted by xastirx (Post 13827601)
If anyone does come up with something I haven't tried yet, i'll attempt it if possible.

Wait patiently for Cryptic to find a solution?
I think we've done all we can from our end...short of a reformat with new STO accounts.


All times are GMT -7. The time now is 03:42 AM.