Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Feature Episodes, Events and PvE Content (http://sto-forum.perfectworld.com/forumdisplay.php?f=122)
-   -   Defend Regulus Sector (http://sto-forum.perfectworld.com/showthread.php?t=96981)

Archived Post 02-01-2010 04:58 PM

Defend Regulus Sector
 
Ever since the last emergency server shutdown, I've been stuck on the defend the Regulus Sector mission. I've destroyed all nine squadrons at least six times now, and I'm still stuck at 2/3. Is anyone else having this problem?

I've tried

Destroying all 9 squadrons.
Exiting to sector, re-entering, and destroying all 9
Exiting game, re-entering and destroying all 9

This is really important to me since my uddies and are saving all nonrepeatable missions to do together, which means I have no other way to level up outside these defend missions. I'm going to try dropping the mission now and grabbing it again and see if that works.

Archived Post 02-01-2010 06:26 PM

yes!
 
I have done it 3 times now and still only have credit for 2/3.

Archived Post 02-01-2010 08:16 PM

I am having the same problem but with Sirius Sector Block. I am stuck at 2/3. This is definently a bug

Archived Post 02-02-2010 12:45 PM

yeah me too!

Archived Post 02-02-2010 03:10 PM

mee also-
 
Plus my character went to warp to Alpha Centauri sector, and I can't log on to him for the last two days after multiple attempts. Anyone else have their toon flying at warp that they can't get to now?

Archived Post 02-02-2010 04:58 PM

Also not getting credit for defend sector. Pi Canis is the same done it multiple times dropped the quest and restarted but still not getting credit for killing the groups after taking down all 9 of them at least 3 times now.

Archived Post 02-02-2010 06:51 PM

Try dropping it and picking it up again. Double click on the quests.

Archived Post 02-02-2010 09:10 PM

Ditto... 2/3 in Regulus after numerous completioins


All times are GMT -7. The time now is 05:31 PM.