View Single Post
Career Officer
Join Date: Jun 2012
Posts: 149
# 91
05-21-2013, 02:40 PM
It seems lots of players are having lag issues today. I am one of them and several of my friends from all over the world. I know because I am talking to them on my teamspeak 3 server, which by the way I host at the same location my game pc is at, and they are reporting the same laggy issues with STO. Several of them stopped playing STO and tried other MMO games like LOTR and WOW, etc. and are not experiencing any lag conditions at all. I have checked my connection to my ISP and all is good with no problems when I play other games on-line. So my point here is simple...

The only lag issue I and my friends are having is with STO. That makes it clear that something in the networking site of Perfect World/Cryptic is having issues and causing this lag.

Brandon, I would suggest that a network engineer or engineers at Perfect World and Cryptic connect a network analyzer to your routers/firewalls/load balancers/servers, etc. and try to pin point what system is having issues. One or more of the account servers and or game servers has some serious problems and it is causing serious lag for lots of players around the world.

Having people check their own systems sounds like it is the solution, but when the lag is reported by players all over the world and they don't have issues with other MMO's, then that solution does not work.

I am a Network Engineer and I do this type of troubleshooting every single day for my global company and I have over 35 years of experience in Networking so please trust me when I say you need to look at your networking equipment and start looking for a process that is hung or faulty equipment or bad code.
Creator of Olympus - Home of the Gods
"I don't test my code often, but when I do I test it in Production"The most interesting dev in the world

I rather be a fence post in Texas than the King of PWE