View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8 Problem partially solved.
01-12-2010, 02:03 PM
Okay, I've got an intergrated RealTek HD Audio chipset giving me the silent treatment as well. I also have some USB headphones, and I figured out how to get the sound working in a very roundabout way.

First, I set sound output in STO to use my USB headphones. Nothing happened, sound was still absent. I closed the game.

I restarted the game client- the sound worked in my USB headphones. I went into the Options menu, and switched to my RealTek HD Audio, and lo and behold, sound! Glorious sound! Unfortunately, it only works for that run. You have to remember to set STO's audio output back to the USB headphones before you exit, otherwise you'll lose the just-gained sound on your next client start and have to redo this jury-rigged fix.

This is a downright bizarre bug, since there's absolutely nothing wrong with the game's sound system per se, as it worked fine once I figured out how to do an end-run around the normal startup sequence. It looks like there's some issue with how the game initializes its sound subsystem that prevents it from properly starting in limited situations.