View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 29
01-13-2010, 02:38 PM
Quote:
It is rather disappointing to have downloaded the client twice only to get incomplete (6.4gig file from FileShack)
Great, just what I want to hear, as that's the only one that would download at a decent speed (currently hovering between 400-550 kb/sec and it's telling me 3 hours to finish).

Quote:
You ladies should use the bittorrent download. Took me no more than 3 hours to download the client from start to finish on a shoddy connection.
Tried that, too, and it was hovering between 2 days and... 25 days to finish. No one was seeding it, and it was worse this afternoon than it was at 3 AM.

Also tried the downloader, and that was the most pitiful download speed I've ever seen, wouldn't go above 0.25 KB/sec, and most of the time sat at 0.

I didn't pre-order and just figured I'd give the game a shot because I've always wanted to try a sci-fi MMO, but I'm not going to spend several days trying to download the game. If the Fileshack download is corrupt or incomplete, I'm done.

Edit: Also, for those of you who said the file was corrupted, I hope you saw this posted on the official download page:
Quote:
Please note that some of our partners host the client as one large zip file, which requires a third-party unzipper like WinRAR or 7-Zip to open. (Windows' unzip tool will corrupt the zip file.)