View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-14-2010, 08:22 PM
According to the download, minimum requirements are a NVIDIA GeForce 7950. You have a NVIDIA GeForce4 MX 4000, which is too low of a model. You have to update your video card.