View Single Post
Captain
Join Date: Jun 2013
Posts: 1,729
# 3
02-13-2014, 02:28 AM
Quote:
Originally Posted by achatefw View Post
My new Romulan Solanae does not convert to tactical mode. The button is a nice 1 minute timer, but the proton cannons never become active nor is there any animation of change.

Is anyone else having this issue? I've already placed a bug report but since everyone I know has the FED version which is working fine, I have no one to compare with. I'm sure there are other Romulans out there with the new destroyer and I'm trying to figure out the issue.

So far I've tried:

Converting in combat
Converting out of combat
Converting with equipment
Converting without equipment
Converting with BOffs
Converting without BOffs

Any other ideas would be nice =)
Are you sure you are hitting the right button? (i know obvious)
Have you tried readying a different ship and then readying the DSD?
Beamed down then up again?
Did it work in the FE?
Inertia just means you can do Powerslides in you carrier!
I am Il Shadow and i approve these Shennanigans!