View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-22-2010, 06:27 PM
Quote:
Originally Posted by Viper358 View Post
Alright I ran into a problem. It ran the installer fine but after install when I open the Star Trek Online.app a Microsoft DirectX installer pops up. If I choose to continue it installs some .dll files and says its finished however on clicking the finish button the cursor turns into an X and the application closes, if I choose to not install I get the X cursor and the app closes.

My system specs are:
Mac Pro, 2 x 3 GHz Dual-Core Intel Xeon, OS 10.4.11, 5GB RAM, ATI X1900 XT

Edit: I'm re-installing from scratch as I think I missed a step.

Update: I got the launcher to open after install, it kept giving me IE script errors but I just selected yes to running the script and it started patching. It patched to about 200 MB and the launcher closed, when I reopen Star Trek Online.app I get the same DirectX install thing as before.
X1600s and X1900s are known WIne graphics issues.. so don't expect too much...

I have never seen it prompt for DirectX... if it does, you do NOT want to install it, even if it works, Wine will run faster using its own directx files, and not MSes.

Answering yes to the script errors is needed... I forgot about that...

I also noticed a bug when i tried to do a full install from scratch, that occasionally the patcher would disconnect and close... it was odd... but when starting again i never had DirectX pop ups.

If you had it install any DirectX files, you need to start over again with a clean version of the wrapper... do not let it install anything DirectX related if it prompts.