View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-31-2010, 04:04 PM
Originally Posted by ****tor View Post
I have a similar machine and to make it work best, I set my game to Fullscreen and lowered the game resolution, in the Video options (It was at 1600X900 initially and I put it at 1280X720). Fixed about all my slowness issues, really!

Here: AMD Athlon II X2
4Gb Ram
Nvidia GeForce 9200

This was my fix as well.