View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Please help me play this game.
02-04-2010, 02:24 PM
With preorder and open beta I have had this game for about 2 weeks. I have amounted 5 total minutes play time. In the first few days I could get into the game but was rubberbanding like crazy and unplayable. In the past week, I havent even been able to get into the game. Everytime I log in I either get disconnected immeditaely. Or every screen hangs. Like it takes me ten minutes from the retreiving characters list, to the point where I can select a character. Of course I dont have a character because I have never gotten far enough to save one, so I have to cliick on create a new character. If I'm not disconnected. I then have to wait another ten minutes until I choose class. This screen hangs for another 10 minutes until I can design my character. So the farthest I have gotten in the past few days is the character design screen, but not far enough to actually save the character. I get disconnected or a crash before then. And now sometimes when I get disconnected it is kicking me off the internet too. I should also mention that many times on the character design screen a lot of the text is missing or messed up. Some skills or attributes are listed as "untranslated" with markings.

Is this a connection issue? Because I have never had any trouble dl the path through the launcher, and I can get to character screens but it just takes forever. All the while my heat is going through the roof. I am at my rope's end here. What is the problem?

I have a wireless connection from a linksys router. I havent had trouble like this with any other game before. Should I open ports? What are some things I should consider? I turned the firewall totally off.

Could this be a video card or driver issue? My video card runs hot but would that keep kicking me off and making the load times so bad?

Please help, I want to play.