View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-21-2010, 05:24 PM
Quote:
Originally Posted by bolbod View Post
***SPOILER***

Hi, I have gotten stuck in the mission titled "The New Link"

I have done the battle portion of it, everyone died (whoopie), and then the U.S.S. Indianapolis blew up. I figured there would be pods to rescue amidst the true way ships to destroy, but after defeating all the true way ships, I have flown around both planets and a little ways off into space and found ZERO pods... what am I missing (besides my mind, rationality and ability to think for myself obviously)??
The pods are rather small and easy to miss. IIRC they'll be in the general area where the Indianapolis blew up. For me, it was kind of tucked into the broken planets debris field. I kinda stumbled into them. Not sure if they're always there, give it another look. Otherwise, not sure what else to try other than drop it and redo it.

Quote:
Originally Posted by Rick_V
im stuck as well got down to the planet and did all the fighting and once it said to go talk to the changeling i found it but cant talk to it whats did i do wrong??????????????
Yours sounds bugged. When you get to the pool, you kill three or four more soldiers worshipping by the pools edge, then, IIRC you talk to a changeling in the pool who will tell you Lass is not a part of their link and hands him over to you to face justice. If The changeling isn't talking to you, then best bug report it. Unfortunately, aside from dropping the mission and redoing it, there's not always alot you can do.

In OB I hated having to redo a bugged mission from the beginning again. I tried beaming back up to the ship and then jumping back into the mission, but it would always just drop me at the same spot where I was bugged. I hear there's a timer. If you log out for 15-20 minutes and come back, you can restart the portion that bugged. Being the impatient type, I also found you can beam up to the ship and go to an adjacent system. Enter it and then leave again right away. no need to stay, just have whatever mission it offers pop up it's dialog on your screen, then dismiss it and leave. when you go back to your mission, you should be able to continue from the start of the ground portion.

Still sucks having to start the ground portion over again, but that's the last part and it beats doing the whole damn thing all over again. It worked in OB, give it a shot.