View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-23-2010, 10:15 PM
This is the same issue I had in Champions Online (and one of the main reasons I stopped playing that game). One of the primary reasons that was being circulated in the CO forums by the devs was that graphical displays were taking precedence over the actual mouse or keyboard command (meaning power A would have to finish 'displaying' before your click to activate power B would work). They were working on the issue, but since I no longer play that game I don't know if they resolved it. From what I can tell of ST:O, they have not.

Another issue I have that is uniquely ST:O is that activating skills (Cannon - Rapid Fire, High Yield Torpedoes, Jam Sensors, anything) interrupts my cannons, meaning my weapons stop firing. All of them. That sucks royal moose ass considering that all the skills are short duration, and basically I'm getting short-changed by a couple seconds each time I activate a skill. An additional 2 seconds of Rapid Fire is A LOT from a T3 escort.

Content will come, bugged missions will be fixed, but this is the kind of stuff that will drive people from the game. People that accept the birth pains of a new MMO. The UI lag was so bad in CO I stopped playing and it looks like the same coding issues have migrated here. This issue is a game-breaker for me. I draw the line at not being able to activate powers/skills reliably. I have a life-time subscription, but I WILL CANCEL if this issue isn't fixed. I don't think a reliable UI is too much to ask from any game, even at launch.


Z