View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 41
06-05-2010, 11:27 PM
Quote:
Originally Posted by Phoenix_Lord
Thanks for creating this.
You're welcome. And thanks for the kind Private Message!

Quote:
Originally Posted by boomaster View Post
Fantastic utility, really worthwhile and I hope it's stickied ... I've got the latest (2.1) version and i've discovered a small flaw. Where you enter the ship type (for that bonus) the field auto-populates with what you have entered ie: i type S, corrects to S=Science Vessel. ... That is probably a really bad explanation but hopefully you get what I mean.
Thanks Boomaster and I appreciate the constructive info. Yeah, I know about that "bug" - It's not really a problem with the sheet so much as you've got your "Enable AutoComplete for cell values" turned on in your Options. With that Option activated, Excel checks the column you're in for any other value that starts with the same thing you're typing, in this case the letter S in B28 matches S=Science Vessel in B32. Mircrosoft. You're welcome. To work around you can A) Change the D31 cell formula as it sounds like you've done. B) When you type the S, next also press the [DEL] button, this will remove Excel's AutoComplete, leaving just your S, or C) Disable your AutoComplete Option.

All that said, I agree, it's annoying... It pops-up when I put in C and get C=Cruiser and have to instead press C[DEL]. I hate that too. With an earlier version of the calc I had the ships listed in Column A, so they didn't trigger the AutoComplete, but when I added the Klingon ships I needed the space.

I'll tinker and see what I can do to move the ship list out of Column B so that it doesn't trigger. I could go with a pop-up comment, but I'm concerned people might not see that... I'll play with the layout and get you an update soon.