View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 397
08-07-2010, 12:08 PM
Quote:
Originally Posted by sxxxxe
Hi there, i just installed STO but after start i only get this mentioned white screen and nothing else.

I installed ie7 and corefonts with winetricks too.

Is there anything i have to do to get rid of it?

Here is a screenshot:

http://www.abload.de/image.php?img=sto-white4vgz.png
That screenshot shows a line stating "Failed to init Gecko", I'm no expert however in my mind that would tell me your IE7 install is broken.

I noted a later edit to your post saying you can now enter login info but cannot click on patch, I still think IE7 is the problem even though it is semi-sorta working, I would recommend trying IE6 instead.

As far as getting rid of IE7, without reinstalling everything all over again, a sloppy and unrecommended hack would be to simply delete the folder IE7 installed to then install IE6 by running the command “winetricks ie6″. If it doesn't work you might just be better off with a fresh new .wine folder as Winetricks recommends.

Quote:
Originally Posted by http://wiki.winehq.org/winetricks
How to remove things installed by Winetricks

Winetricks does not provide a way to uninstall files it installs. This is for several reasons, but mainly because the preferred way to uninstall anything in Wine is to simply install into a fresh .wine directory.
Personally I'm on a BSD box not Linux, and I had much better luck using IE6, when I tried IE7 it was all borked up.

I posted an article online about what I had to do to get STO running for me, it may or may not be of help to you or others.

The article is here - [ LINK ]