View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 202
11-06-2010, 01:52 PM
Anyone applying these tricks using a Saitek X45 or X52?

I have found a technical issue, determined it's cause, and am now seeking a workaround.

The issue is found on, but not limited to, Saitek X52 and X45 HOTAS joysticks. The issue is the 2 sliders (Mode and Aux) are continually transmitting their position (1 of 3 positions, in each case) as Slider1 and Slider2. These override some but not all signals from the throttle. The solution in other games is to have the game ignore/disable these slider's signals:

This problem is normally caused by certain joysticks and other input devices that have buttons (or more commonly switches) which send a continuous signal to the game. This effect causes some problems with the way DirectX handles joystick/joypad input, and leads to the keyboard repeat problem. The most common devices to cause this are Saitek X45 and X52 joysticks, but these are not the only ones to do it.

The fix for this is to ignore one or all of the buttons that is generated by the switch, and X3 includes a means to do this. To ignore a button, follow these steps:

Locate the shortcut to X3 that you use to play the game (Start Menu, Desktop, Quick launch, etc.).

Right click on the shortcut and select Properties.

In the Target box, add the following to the end of the command listed in the box:
-ignorejoy 1
Replace 1 with the number of the button to ignore - may take some trial and error to find.

Add another -ignorejoy N entry for each additional button to ignore

Click OK

Repeat for any other shortcuts you use to launch the game

Hopefully that will take care of it although it is possible that this won't be a complete workaround for some hardware.
Unfortunately, this is not for THIS game.

What I am seeking is either a shortcut switch or a command line I can use to disable Slider1 and Slider2 inputs to STO. Any clues as to what might work?

I will re-post this in the technical support thread as well.