View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Map bug: Prometheus bridge
03-04-2011, 09:02 PM
I hadn't noticed this problem at all before the Foundry was taken down to add branching dialog, but after returning to my in-progress mission when the Foundry was opened for player use again I noticed something that has currently broken my mission, making it impossible (at least from everything I've tried) to publish it once it's finished.

One of the maps, specifically the Prometheus bridge (or "Bridge Prometheus 01" as it's called in the Foundry) is now offset compared to the map when viewed in the Foundry map editor. Due to this, anything that was previously correctly placed on the map is now considered off-map. If I move anything in an attempt to fix this, it *actually* takes them at least partially off the map, breaking it.

Currently, the actual map (what you see when playing) is placed higher up on the map editor than what's displayed, and I assume part of it clips off the map image at the top. Everything I've tried so far to fix this myself has failed, since I can't seem to reposition the map so that the Foundry doesn't flip out at me anymore with a "Component is out of playable bounds [UNTRANSLATED!]" error that prevents me from publishing.

Interestingly enough, about the map image: unlike the map in the map editor, the minimap displays in the correct position compared to the actual map you see and move around in.


Just to make sure it's clear, the components on the map are not, I repeat, *not* out of playable bounds, but due to the map bug the Foundry thinks they are, locking out the publish button. Therefore, when this mission is completed, it will be impossible to publish it unless this bug is fixed.

EDIT: I forgot to mention, I've already tried making a new map with the same intended look, but I got the same problem with it.

Please Cryptic, I hope this can be resolved soon, as it's keeping me from publishing a mission I've put a lot of work into and I'm sure must be affecting anyone else to use this map, in the same way.

P.S. I also found a bug in the "Great Bloom USS Warwick Interior" a while back that hasn't been fixed yet. There's a horizontal polygon hole in the bottom of the doorway connecting the corridor with Main Engineering (where the warp core is), and I can see through the map into nothingness through it when viewing it from the corridor. It's very immersion breaking.