View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 What a (bug ridden) return
01-28-2012, 06:05 PM
Ok so after a year away from STO I thought I'd come back and give it another try since it went FTP.

First I get to respec everything. Ok, that's fine. Except every time I press the (highlighted) accept button nothing happens for 2 seconds, then everything resets again. And again. And again.

My ship won't move, even on full impulse power. I can see all the other NPC ships cruising around spacedock, sure wish my engines worked too.

I don't appear to have any weapons, armor, kits or other equipped items on my character or any crew members. My inventory is still there, just all that other stuff is gone. My ship still seems to be fully equipped so I'm really not sure what's going on there.

Yes I force verified all the files on my installation. Multiple times. I also tried submitting an in game ticket to a GM, only to get a server time out dialogue box when I pressed submit. Didn't kick me from the game but there wasn't much point staying logged in for much longer.

Is there some drastic server issue causing all this? Was my character data simply corrupted? Should I keep trying to get this to work again or give up?