View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
Went to DS9 tonight to get some new gear. Beaming down to DS9 starts playing this super loud grinding noise.

I turned off ALL sounds in game, it's still there. The minute I beam off DS9, no problems.

Using a Razer Megaldon headset, works fine in Ventrilo, Skype, every other game I play.

Help?