View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 113
03-06-2012, 06:19 AM
Quote:
Originally Posted by aashenfox
I'm having an odd problem with the demo viewer. After working fine a few times, it suddenly won't open. Or at least it opens, immediately minimises and cannot be restored to the screen. I've tried running as admin, removing the 'downloaded exe' flag, deleting it, downloading it again, clearing out my demo folder, nothing makes any difference. It could be a windows problem, but this is a fresh build, it was installed only a month ago.

Any ideas? I'm a tech consultant and systems auditor professionally for 18 years, and an amateur programmer, so feel free to get as technical as you like.

Thanks in advance.


Quote:
Originally Posted by RachelGarrett View Post
Hi,

try the following:
  • Open Windows Explorer
  • Type in "%AppData%
  • Open "StoDemoLauncher"
  • Delete the config.ini

The problem might be that you have been switching screen resolutions. the tool remembers the window position in absolute coordinates. If the screen resolution was reduced since last use, it might have ended up "outside" of your screen.

Regards,
Rachel
Quote:
Originally Posted by RachelGarrett View Post
Ok, I updated StoDemoLauncher to prevent this behavior from happening in the future:

2.9.5
- If location and size stored in config.ini would place window outside the screen, it is repositioned to fit within the primary screen desktop.

I also found an additional bug in the auto-update system, immediately after 2.9.5 was released, so here comes:

2.9.6

- Fixed a bug where the auto-update system would display a wrong download version number.

Regards,
Rachel

P.S.: Please tell me if this causes any issues with multi-monitor setups (because I can't test that on my one-monitor machine).
Hope this helps