View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
Hey guys. I keep seeing forum threads popping up for the same issues over and over again. To avoid cluttering up this forum with stuff that we, the devs, are already well aware of (and working hard on, I assure you!), I'm going to go ahead and make this post to keep track of known issues and workarounds or fixes.

If you want to post about any of these issues, please try to limit it to one of the (many) existing threads instead of making more new threads.

Some polygons show up black in random places under DirectX 11 mode
THE WORKAROUND: Switch to DirectX 9. You can do this in the video settings if you turn on "Show advanced settings" and then expand the tab at the very bottom for troubleshooting. Select it from the video card menu.

THE FIX: We're still working on that one.

THE UGLY TECHNICAL DETAILS:
Caused by bad model data. We're aware of it, and working on fixing it, but we have to go through and fix up a ton of models.

This only affects people using the DirectX 11 renderer, so if it's driving you totally nuts, you can switch to DirectX 9 mode. We haven't actually started using any fancy DirectX 11 features that don't exist in DirectX 9 yet, so ther only difference is a minor performance one.

It's one of those cases where something was wrong all along, but until we started using DirectX 11, it didn't matter. I guess DX9 was a little less strict with its interpretation of model data.

FORUM THREADS:
http://forums.startrekonline.com/sho...d.php?t=251947
http://forums.startrekonline.com/sho...d.php?t=250404
http://forums.startrekonline.com/sho...d.php?t=248928
http://forums.startrekonline.com/sho...d.php?t=246919
http://forums.startrekonline.com/sho...d.php?t=247275
http://forums.startrekonline.com/sho...d.php?t=246941
Stars render in front of planets / planets look semitransparent / flickering nebulas
THE WORKAROUND: None yet.

THE FIX: We're working on it.

THE UGLY TECHNICAL DETAILS:
Some of our sky domes (that is, a big sphere with a stars background texture) are not rendering at the right depth, causing them to show up in front of planets sometimes, or at the same layer as nebulas. We're still fixing up the sky domes. We used to do some trickery to make sure the depth values would always end up squished to the very edge of the range, but that was causing some other issues and due to other developments, it's no longer feasible.

FORUM THREADS:
http://forums.startrekonline.com/sho...d.php?t=263691
http://forums.startrekonline.com/sho...d.php?t=263295
http://forums.startrekonline.com/sho...d.php?t=247134
http://forums.startrekonline.com/sho...d.php?t=249742
http://forums.startrekonline.com/sho...d.php?t=253160
http://forums.startrekonline.com/sho...d.php?t=252586
http://forums.startrekonline.com/sho...d.php?t=249798
Screen renders as a blocky mess using AMD video cards.
THE WORKAROUND: Downgrade your AMD graphics driver to version 12.1.

THE FIX: AMD is working on it.

THE UGLY TECHNICAL DETAILS:
Version 12.2 of the AMD driver has something horribly wrong with it. AMD is (hopefully) working on a fix for this. It's not just affecting our games.

You may have to completely uninstall your AMD driver before installing the 12.1 version. It's been reported that the driver rollback feature didn't work for someone.

FORUM THREADS:
http://forums.startrekonline.com/sho...d.php?t=263130
http://forums.startrekonline.com/sho...d.php?t=263321
http://forums.startrekonline.com/sho...d.php?t=259428
http://forums.startrekonline.com/sho...d.php?t=260437
http://forums.startrekonline.com/sho...d.php?t=261411
User interface issues
These should probably go in the Gameplay Bugs forum (that's probably where the UI programmers would look first)...
http://forums.startrekonline.com/forumdisplay.php?f=69
Help! My issue isn't in the list
Now you should post a forum thread about it.

And REMEMBER TO POST SCREENSHOTS.

Seriously though, post screenshots. We basically can't do anything without them, regardless of your ability with words and description.