View Single Post
Lt. Commander
Join Date: Dec 2007
Posts: 120
This is an annoying issue - but I cannot remove my duty officers from active duty. Clicking the "Remove from Active Duty" button does nothing, and double-clicking on the DO has the same result (nothing). This is true for both space and ground. I've tried hitting the button to remove them and logging out, with no success. I've tried selecting different officers - same thing.

I can sorta "replace" one of my DOs, but it will only allow me to change the DO that was last placed on active duty, effectively locking in 4 of my duty officers permanently. Is this a problem for anyone else?

*****
Edit: As per the comments below, I tried the drag-and-drop method. It works! Appropriately, I downgraded the bug from Critical to Really Annoying. Sadly, the two more obvious interactions (clicking the huge glowing button and double-clicking) still will not work. I really suggest Crypic get their UI people to fix this, as I can't be the only one this is happening to and its likely to be very frustrating to users who don't read the forums.