View Single Post
Career Officer
Join Date: Jun 2012
Posts: 177
# 2167
08-04-2012, 07:27 AM
Quote:
Originally Posted by celebrin7 View Post
Hey guys,

I've got an OS X 10.5.8 , so when I downloaded the 1.4.1 version, it said it cannot run on my mac. Then I got the 1.3beta3 version. I ran it and chose the STO .exe file to be loaded I got the terms, pressed "I agree" and then a loading window appeared as if the game was installing. It says "Executing pre-installation actions" but the bar never loads. It stays empty for hours.
Any idea what's wrong and how it can be fixed?

Thanks, and sorry if this was already brought up before.
sorry, but I have no clue if the old versions still work right at all...

10.5 is ancient, you really should update some.... at LEAST to 10.6, but if your machine can run 10.8... 10.8 is really good.