View Single Post
Ensign
Join Date: Aug 2012
Posts: 23
# 2
11-26-2012, 08:25 PM
Have you tried going into the character status window and checking to see if you have your body armors visual's toggled on/off. You can right click on your equipped armor to enable or disable those.