View Single Post
Commander
Join Date: Jun 2012
Posts: 441
# 90
12-24-2012, 01:09 PM
Quote:
Originally Posted by andyslash View Post
Lets name the online games i play:
WoW: no lag
Team Fortress 2: no lag
Call of duty modern warfares 1 and 2: Barely lag
Half life 2 deathmatch/garry's mod: no lag
grand theft auto IV online: no lag
Star wars The old republic: barely lag
battlefield 2 bad company: barely lag
Transformers fall of cybertron/war for cybertron: no lag

This is THE only game that has severe lag. id submit a report, but it still wont help. They'd say working as intended just like every other bug.
It does not matter what other online games have no lag--I know I'm going to take some flak for saying this, but why is that the first justification people use for blaming the server/company, besides "I have a super fast internet connection and an expensive new PC"?

Different games traverse different routes to their respective servers. It's much the same as going to two different houses some distance apart--you don't necessarily take the same streets to each one, and what affects one street isn't necessarily going to affect another.

What matters is the route that STO takes to its server. Unless you've done the basic diagnostic tests described in the sticky "Diagnosing Lag and Rubberbanding" and therefore would have some snapshot of what's going on with the transit between your PC and STO's server, don't be so quick to point your finger at the company.
****
Lagging, D/Cing, or rubberbanding? Here's some help.

Current ships: A lot. RTR 15 National Championships....and counting

Last edited by lewstelamon01; 12-24-2012 at 01:13 PM.