View Single Post
Starfleet Veteran
Join Date: Jul 2012
Posts: 7
Quote:
Originally Posted by robertdamon View Post
Hi, apologies if this bug's already been documented - I had a pretty good scan but couldn't see it mentioned.

Just tried to switch bridges in the ship editor on my Armitage Heavy Escort Carrier to one of the Prometheus bridges (which I'd bought months back). When I clicked 'Purchase' to save the changes to my ship I was told I needed to buy the Armitage again. It was listed as 'Free' as I've already bought it, but then when I clicked 'Buy' I was told it's already in my inventory (obviously). Tried it with other bridges and it simply won't let me switch to another bridge without prompting me to buy the Armitage.

I recently went from gold to silver - wonder if that's a factor, though either way it's a bug.

Also recently noticed switching BOFFs to the TOS outfit (which I'd also purchased ages ago), was often prompting me to buy the pack again.

Have left a ticket, though don't know if they're still looked at these days. I'm not a Cryptic basher, and it's hardly a game-breaker, but it's a bit annoying when you can't access stuff you've paid for. Anyone else come across similar problems with purchased ship or character costumes?

Cheers!

Addendum: Did some more testing and I cannot make any changes to my Armitage on my main toon without being told I have to buy the outfit again - which I can't do. Ship parts, windows, hull, bridge, nothing. But on my Fed alt, no problems.
Quote:
Originally Posted by robertdamon View Post
Eventually managed to work around this bug by stripping the ship of equipment, discharging it, then reclaiming it from the Zen Store. Bit of a pain having to reconfigure stations, trophies, equipment etc. but can now successfully change the bridge in the ship tailor.
I was having the issue when trying to customize the ship in Ship Tailor. I could not save bridge or even paint scheme that i wanted. I can confirmed that I had use work around and it fixed the issue without any problems.