View Single Post
Ensign
Join Date: Jan 2013
Posts: 4
As you guys know, it is not the specs that matter but I will put them down for you guys to inspect anyway:

CPU - Intel Core I7-3770K @ 3.5GHz, 3501Mhz, Quad Core

Motherboard - Sabertooth Z77

GPU - NVIDIA Geforce GTX670 CU II Top

RAM - 16GB DDR3 2000Mhz

OS - Windows 7 Ultimate x64 Bit

Hey, as soon as I came out of killing the borgs as I went into the Tactical career, and went into the space station to go see the Admiral, my character did not show up in the space station, I could see other players moving around me, but doors would not open for me, I could not interact with anyone, and every minute I would get rubberbanded back to where the transporters are, ever since then I could not move my ship, or do anything on this PC (I got out using another PC in the household). PLEASE HELP ME

I login and select my character, press play and starts to load me into the game, but it starts to load slow at around 55-80%, then when it finally loads to 100 after 5 minutes or so I can't move anywhere, only turn left or right at fast speeds or up and down at normal speeds, the game does not load my ships weapons or abilities, my crew, or my characters equipped items, but for some reason it lets me send friend requests but that is all, chat loads sometimes but not all the time and I can't get it to send anything into chat.

I have tried disabling Network iControl, updating drivers (some drivers did not seem to let me update them), I tried logging in on a different computer in the household (worked fine), renewed the launcher and nothing....