View Single Post
Commander
Join Date: Jun 2012
Posts: 441
# 2
01-15-2013, 09:20 PM
Quote:
Originally Posted by zeroalexandra View Post
Well, this is far from the first issue I've had with Perfect World's support and last time I was censored here. Hopefully someone can actually bother to deal with my issue rather than just shut me down and drive me out again.

So, we have the ultimate game card promo going on. I have a $25 card with no option to redeem a $25 card via Perfect World's site. Attempts to get into support lead simply to an error stating,

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept
cookies.

For the record: I allowed cookies on Perfect World's site. The issue has persisted, so I used IE to get into the support website and found Firefox was right! Any and all attempts to get into the "support" or "contact us" areas of Perfect World's site result in a never ending login loop that consistently demands my login credentials and then loops back right to demanding my login credentials again.

Does Perfect World not care about their customers at all? The first time I needed assistance I was shut down and censored. Now I'm just getting a never ending run around loop.
That's been a known issue with the new software PWE used for support around six months or so ago.

You can reach support by direct email here.
****
Lagging, D/Cing, or rubberbanding? Here's some help.

Current ships: A lot. RTR 15 National Championships....and counting