View Single Post
Empire Veteran
Join Date: Jun 2012
Posts: 1,032
# 4
01-31-2013, 11:45 AM
Let's get ready to break an FE!!

Lag City, here we come!

-----------Edit
Qo'noS:
Q's party goer mission:
Got mission from Q
Went to transporter, beam to Academy*click*
Server not Resonding *facepalm*, finally arrive
The old "under which box", cute, easy, finished
Beam to First City*click*
Server Not Responding *facepalm*
Arrive in Qo'noS system soace o.O *facepalm*
Beam toFirst City *click*
Seraver not responding *facepalm*
Arrive in the Shipyard *year-old-bug-facepalm*
Beam to First City *click*
Server not responding *this-has-gotten-old-facepalm*
Arrived at first city, chose anniversary box, got 1k skill booster

I know the Server not responding issue is purely from player log in and just "congestion" of character population is the zones, it's was just a little frustrationg is all. but like bad acne it will clear up.
-----------------------Edit

The new party popper:
Still no UI option to turn that garbage off on my screen without degrading all my visual fx?
Really? Giant freaking ballons? There have been people requesting the option to turn that garbage off since the first one, but now the the trash is giant and floats all over the place.
-----------------------------eDIT

Temporal Ambassador
Nice mission, cute the way you interacted with people. all around I enjoyed it.
The Wisest Tribble... LOL

BUT, after getting the rewards from the mission, I didn't get all the rewards for the mission. I recieved the two ships, no problem, but I didn't recieve the Yesterdays Enterprise uniform. no box with it nor was it straight into the Tailor as an option. Is that yet another Fed only special?...
edit: found it, just a belt and sash... So shouldn't it be called the Yesterdays Enterpris Accessories? not uniform.
Handle: @kirian_darkstar
Registered: Oct/2009 , LTS : Feb/2011
Fleets: Warriors of the Phoenix, Kirian Industries
Three years and still no Captain Klaa hair...

Last edited by darkstarkirian; 01-31-2013 at 01:52 PM.