View Single Post
Rihannsu
Join Date: Jun 2012
Posts: 1,512
Ever since Season 7 introduced the ability to set an active shuttle there has been a bug where ship and shuttle names would appear switched in a character info window and/or character selection screen.

Picture related - http://img213.imageshack.us/img213/6...3033013052.jpg
You can see that I'm flying an Andorian escort, yet the profile shows my current shuttle class and name.

I think I know where the problem lies and you may easily recreate it. Here's what I've observed:

The ship shown in the character info window ALWAYS shows a ship name and class that was PURCHASED/CLAIMED first.

The character selection screen on the other hand ALWAYS shows a ship name and class that was PURCHASED/CLAIMED later.

Ship prefixes, names and alphabetical order in the shipyard do NOT seem to matter in this case.


Here are some examples:
On one char I've purchased a Mobius Destroyer first, THEN purchased Aeon Shuttle. Both are my active ship and shuttle respectively. In my character info window it states that I'm flying the Mobius, but on my character selection screen I can see my shuttle class and name shown as the ship I currently use.

I've tested this on my other toons, where I could re-claim ships and shuttles from the C-Store without issues. On one of them I claimed a Guramba first, and General Chariot later, which resulted in the same situation as above. I then discarded the Guramba and claimed it again (even giving it the same name). Now on the character selection screen I can see the Guramba class and name, while my character profile window shows my General Chariot's class and name.

This bug wasn't that big of an issue until I saw the new character selection screen on Tribble, which not only shows a ship name, but also a graphic of the ship currently in use. The problem is, the ship shown above a character is the one that appears in the character info window... So in the end I see my shuttle name mixed with my actual ship graphic (if the shuttle was purchased/claimed later), or the other way around (if it's the ship that was purchased/claimed later).

Pics:
http://img19.imageshack.us/img19/593...shot001aov.jpg (Mobius purchased first, Aeon Timeship purchased later)
http://img507.imageshack.us/img507/7...nshot002qj.jpg (Chariot purchased first, Kar'Fi purchased later)


May seem confusing, but it's easy to check for oneself, especially on Tribble.


tl;dr steps to recreate
1. Claim a new ship, THEN claim a new shuttle. Set both as active
2. Check ship name in the character info (RMB -> Info) and in the character selection screen info
3. Discrard the SHIP
4. Claim a new ship. Set it as active
5. Again check ship name in the character info (RMB -> Info) and in the character selection screen info
6. Fix the bug