View Single Post
Empire Veteran
Join Date: Jun 2012
Posts: 64
# 1 Low Resolution Blurry Graphics
05-16-2013, 09:21 AM

Whenever i load to a new area, both ground and space the textures are all incredibly low res, almost as if i have the graphical settings set extremely low even though I have them all maxed out.
I have found a highly annoying workaround to get the graphics back to the way they should be, if i go into the graphic settings menu and tick and then untick the Half Resolution tickbox the graphics suddenly become high res again and remains so until i load to another area where i have to repeat the process.

I have tried adjusting the settings in the Troubleshooting section, namely the Direct X version but nothing makes a difference.

A bit of info about my system:

  • OS: Win7 64bit.
  • MoBo: Asus P8Z77-V Intel.
  • CPU: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 8 Logical Processor(s).
  • RAM: Patriot Memory 8GB (2 x 4GB) Viper Xtreme Series PC3-15000 1866MHz CL9 Division 2 Edition.
  • GPU: 2x Sapphire Technology AMD Radeon 7970 HD 1GHz 6GB PCI-Express 3.0 HDMI Vapor-X.
  • SSD: OCZ Technology 256GB Vector Series SATA 6Gb/s 2.5" Solid State Drive.
  • HDD: Seagate 1TB Barracuda SATA 6Gb/s 64MB 7200RPM Hard Drive.
  • Monitors: 3x Acer S240HLbid 24'' Full HD widescreen LCD monitor with LED Backlight.
  • Game Resolution: 5896 x 1080.

* All drivers and system updates are current (and i've even re-installed the GPU drivers to be safe)
** The two GPU's are Crossfired
*** I've tried the game with only one of the GPU's running so eliminate Crossfired GPU issues.

I've been playing other games across my 3 monitors using Eyefinity with no issues for some time now (eg LOTRO runs and displays perfectly maxed out). My system's specs are more than powerful enough, and once i've performed the above mentioned work around the game displays and runs perfectly fine until i load to a new area.

I posted a reply to an archived (necro'd) thread on this forum, but i thought i'd be better creating a brand new one.

Please help me.