Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 All My Graphical Issues FIXED!
02-08-2010, 12:15 AM
I noticed that on my Vista laptop I could see engine trails coming out of the warp nacelles but on my main windows 7 pc, I could not. So I thought i might try reloading directx and viola! Not only do I see the warp trails now, but I am also able to run with post processing, shadows, and dynamic lighting with no problems and my overall framerates are way up! And the game looks better to boot! There are vertain weapon effects I didn't even know were in-game until i did this. Just run a search in google for directx redist feb 2010 ( I downloaded mine from softpedia, about 110mb). It turns out that the version of directx that is shipping with the game is either an older version or has something wrong with it (I remember that the STO intstaller installed something with directx). Try it out and see what this fix does for you!

edit:
i have a 4850 x2, latest ati drivers, a q6600, a 680i sli board, sb xfi, windows 7 ultimate, 4gb ddr2
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-08-2010, 12:46 AM
would this help with laptops? i have to run everything on low to play, not that thats a problem, i enjoy playing without lag :p
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-08-2010, 12:48 AM
it helped my laptop (turion x2, radeon 3200 hd)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-08-2010, 12:49 AM
cool, i have an hd 3200, that my only problem with sto. so what does this fix? upgrades the software so i can run it without half resolution without much fps drop?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-08-2010, 02:48 AM
I reinstalled DirectX and my fps jumped up to a constant 60 fps with most settings maxed. It had been like this during Headstart, but for some reason, the first retail patch made my max out at around 25fps...

However, it is now messed up again after 2 minutes or so in space combat. I saw some green squares on the screen for a second, then the fps dropped. Reinstalling directX is the only thing that fixes it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-08-2010, 07:23 AM
Im going to roll with yer problem over the next few days, maybe we can come up with a permanent fix for you. You may know a lot of this already but im going to give full descriptions on how to do everything just in case others with problems are reading as well.
First, ill need you to post your hardware, operating system, and current drivers for your vid card.
Second, have you tried the maxfps fix or are you running with vsync enabled? the max fps fix is applied by double clicking on the star trek online icon on yer desktop, then while in the launcher BEFORE actually giving your password, go to options at the top. In the "Advanced Command line" field type "/maxfps 60". Then sign in and launch the game. After you first login and see your ship, press escape then choose options then video at the top. Make sure that "Monitor Vertical Sync" is on. If that didnt work have you tried turning off some of the advanced features?
The third thing we will try is turning these off. In the esc->options->video menu click "show advanced video settings". Turn off Dynamic Lighting, then turn off Post Processing, the turn Shadows to Low or off (may require a game restart). If that didnt work, have you tried doing a full driver reload?
The fourth thing we will try is doing a full uninstall then reinstall of your drivers. Most ppl these days dont FULLY uninstall drivers before reinstalling them. First go to google and run a search for "Driver Sweeper". Then click on the Guru3d link at the top and download the version with installer. Next go to your download location and right click on the exe and choose "Run as Administrator" if on vista/7 or just double click on it in XP and install the program. Next go to your graphics card drivers website and download the very latest drivers for your video card. Then, go to control panel, then add/remove programs on xp, programs and features on vista or uninstall a program on win7, find your drivers (will say ati or nvidia) and choose uninstall. The ati drivers will ask what you want to uninstall, choose express uninstall, nvidia will ask you what to uninstall, just choose the graphics driver from the options. After the uninstall, reboot into safe mode my doing a restart and then as your bios is getting finished posting, press F8 a few times until you have the option to choose safe mode then press enter. When in safe mode, run the driver sweeper program that you installed earlier and make sure to check which drivers you are using (for nvidia choose nvidia display and nvidia physx, for ati choose ati). then click analyze and clean. after the cleaning is done, reboot your computer and let it fully load then run the graphics driver you downloaded earlier, then reboot. If you are still having the same problem after all of this, let me know, we can start applying other fixes from here...
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 01:03 AM.