Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
I have noticed while doing the standard "Patrol Sector" missions, sometimes the mission is not completing and being cleared off my list. The pattern seems to be if you enter a sector on patrol, and auto join an instance as you zone in, if you were not zoned in before the first objective was completed, the mission will not get flagged as complete.

For example;

Your mission entails patrolling sector X and defeating 5 enemy squadrons while there.

1. You zone into sector X.
2. As you zone in, you are auto teamed joining other players already in the instance.
3. If the other players defeated the first enemy squadron before you zoned in, the mission will not complete for you and you have to redo it.

This does not happen all the time, yet it is frequent enough that it warrants a look.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-10-2010, 12:56 PM
Thank you, I have forwarded this to the dev team for investigation. I do have a couple of questions though that might help them.

Have you found that you are often auto-teamed with groups that have already completed the first objective?
About how often does this cause the mission to fail for you?
Do you recall the names of any of the missions where this has happened?
How were you able to continue, after the mission had failed to complete?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-10-2010, 01:16 PM
Thank you for the response.

To answer your questions;

1. It is entirely random. Sometimes I am auto teamed with someone who has completed the first objective, sometimes not. It is essentially luck of the draw.

2. I would say this causes the mission to fail 99% of the time IF I zoned in after the first objective was completed (I believe this is the key to it). If I am auto teamed while zoning in and no objectives had been completed yet, the mission completes with no problems.

3. I don't recall the specific system names off the top of my head, but this happened while playing characters of varying level on the Federation side. I was doing patrols in Iota Pavonis on one character and patrols in the Bajor/Cardassia sector on the other. If this happens again I will append the specific system / mission names to this post, but I do not believe this is isolated to one area.

4. I was able to continue by exiting the patrol system and dropping the team, then re-entering the system and completing the required objectives. The first few times I encountered this, I just repeated the mission after exiting the first time and then it cleared.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
03-10-2010, 04:26 PM
Quote:
Originally Posted by GM_Litana
Have you found that you are often auto-teamed with groups that have already completed the first objective?
Yes. This also occurs and is reproduceable if none of the initial objectives have been completed, but the auto-team members have already instanced the map and clicked through the initial mission dialogs to get the "acquired mission: xxxx" message. In my client, I will have the mission and objectives displayed but never receive the "acquired mission" confirmation. When the mission is completed, the objectives are all marked successfully completed BUT the mission does not complete because the game client appears to believe I never received the actual mission assignment.

Quote:
Originally Posted by GM_Litana
About how often does this cause the mission to fail for you?
This is always reproducible in patrols and episode missions in the scenario described above. I have not noticed this problem in fleet actions UNLESS some of the initial objectives required for mission progress have already been completed. Note that exploration auto-teaming never works (by design?) and I am also unable to get more than 1 team member to instance into the same exploration mission with me on already established teams.

Quote:
Originally Posted by GM_Litana
How were you able to continue, after the mission had failed to complete?
In all cases, drop the mission and re-acquire. In some cases I will also need to disable auto-teaming and solo the mission due to the volume of new players starting the mission and reproducing the same set of circumstances repeatedly.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
03-10-2010, 05:02 PM
Thank you so much for the information, everyone! I really hope that this is the only thing causing these problems, since it's been nearly impossible to reproduce internally and difficult to find reproduction information.

Now, has anyone gotten a mission and actually done it solo (not teamed at all), and run into problems completing it properly? My hope is that this set of circumstances is the only one we need to worry about.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
03-10-2010, 05:44 PM
As an update to my previous post, this seems to occur on any patrol or episode mission where the mission aquisition only occurs after you click through the initial instance dialogs. Missions that start the mission acquisition before the initial instance dialogs do not seem to have this issue. Unfortunately, the number of missions configured to spawn mission acquisition immediately after zone is very low. Suggest revisiting all of the patrol and episode missions to spawn the acquistion message immediately after zone instead of after the initial dialogs.

Auto-team members joining the map after the initial dialogs have been clicked but before the first objective is completed get instanced into the map with the mission name and objectives, but do not receive the initial instance dialogs or the "mission acquired" confirmation.

Quote:
Originally Posted by GM_Litana
Now, has anyone gotten a mission and actually done it solo (not teamed at all), and run into problems completing it properly? My hope is that this set of circumstances is the only one we need to worry about.
Yes, but the only one that stands out in memory at the moment is Fed Lvl 5 "Stop the Signal". If you die on any space map past the first one, the respawn option will send you all the way back to the first map and then your objective is 200 to 300 km away. The only workaround I've found is to exit back to sector and then continue the mission which will spawn you at the correct spawn point on the correct space map.

*edits*
I've also noticed the same problem above in Fed Lvl 3 Hide and Seek.

Lastly, if you are joining an established team or auto-team that has completed the objectives from the first map and moved on and are just joining the instance, you may end up spawning at the first map while your teammates are actively fighting on a subsequent map 200 to 300km away. The workaround mentioned above for solo play also seems to work when joining team instances.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
03-11-2010, 01:56 AM
Like the other posters Ive also had this issue happen - and have bugged in game with mission examples.

However what Ive now noticed is that when joining a mission where the first objective has been completed, in the bottom right corner of the screen you should have a button called 'Ops' (Same location as the 'Beam to Ship' button is when in Earth spacedock).

Clicking that button should bring up the mission text and allow you to acquire the mission. I joined an open team mission yesterday with one objective left to complete, and through the 'Ops' button acquired the mission, which completed successfully when the last objective was achieved.

I dont remember if that 'Ops' button was there for the other missions where this occured, but should be something to look for first if people find themselves in this situation.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 08:57 PM.