Lt. Commander
Join Date: Dec 2007
Posts: 120
ok so i dont know if this has been addressed or not but i have been wondering why one of the loading screenshots is of the destroyed USS Enterprise from the JJ Abrams star trek, im curious. No flames or attacks against the new movie
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-18-2012, 01:39 PM
I don't think the Enterprise was destroyed?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-18-2012, 01:40 PM
go to Wolf 359 and take a look around, i think the picture is from there
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-18-2012, 01:42 PM
Its one of the few things cryptic did that I love more than the rest of the game
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-21-2012, 12:42 AM
Yeah, it's just a picture of a generic ship wreck.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-21-2012, 12:15 PM
Quote:
Originally Posted by CptBANG View Post
go to Wolf 359 and take a look around, i think the picture is from there
More likely, it's from the tutorial; that's where most people would have likely seen the actual wreck (since it's pretty prominent from what I remember).

I know it's supposed to be an easter egg sort of thing, but I've always felt that Cryptic should make something that vaguely resembles it, just to provide an excuse for that wreck being there (that doesn't require getting permission to use the JJ-prise).

I mean, as it stands, it's accept that that is an alternate universe ship, or try to claim that it's a TOS connie that's had its pylons and nacelles completely warped into new shapes by battle damage. One of those rationalizations isn't allowed, and the other is stupid.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -7. The time now is 02:14 PM.