Lt. Commander
Join Date: Jul 2012
Posts: 176
Any idea where this is.

Could not find it in the shipyard or the barracks.

Help would be greatly appreciated.
Career Officer
Join Date: Jun 2012
Posts: 409
# 2
10-12-2012, 04:46 AM
The fireworks emote is a 300 day veteran reward that's for Fed and Klingons. So you need to sub for 300 days or get a lifetime sub and you'll get it right away.
Empire Veteran
Join Date: Jun 2012
Posts: 236
# 3
10-12-2012, 05:18 AM
stowiki says "at the console (north of Commander Ragen) along the east wall of the Barracks". I searched again and again for my orion KDF. NOTHING! I'm lifetime and I got it for my main toon in fed side (in esd). Once again it's broken for klings. No doubt about!
http://i.imgur.com/RVocq.jpg
Empire Veteran
Join Date: Jun 2012
Posts: 1,141
# 4
10-12-2012, 05:32 AM
I just made a new character to check this for myself, I was able to claim the fireworks device. I took a screenie with my map open to show where the console is so if it doesn't work for you it is most likely a bug.

Screenie
Man is a gaming animal. He must always be trying to get the better in something or other.
Warning, this poster tends to talk nonsensically when caffine levels fall below 80%.
Empire Veteran
Join Date: Jun 2012
Posts: 236
# 5
10-12-2012, 05:43 AM
Ok. Thank you very much. I checked it. I tried with my two kdf toons. It seems there is bug for my two kdf toons
http://i.imgur.com/RVocq.jpg
Lt. Commander
Join Date: Jul 2012
Posts: 176
# 6
10-12-2012, 09:25 AM
Thank you very much for the screenie....I am also unable to claim the emote and I am a recent lifetime subscriber.

I was able to claim the fireworks emote for my fed toons...not for my klink.
Career Officer
Join Date: Jul 2012
Posts: 295
# 7
10-15-2012, 11:32 AM
i too am having difficulty claiming my fireworks... all three kdf toon can not claim,,, but both fed toons have.... ii have no suggestions other than filling out a ticket... hopefully somebody responds.. lol
Survivor of Romulus
Join Date: Jun 2012
Posts: 995
# 8
10-15-2012, 04:07 PM
have u tryed changing instance sometimes that works

ps try logging out and back in
Ensign
Join Date: Jul 2012
Posts: 3
# 9
10-21-2012, 04:40 PM
same here.... couldnt get this firework. Console is offline.

Tried all available instances, logged on and off for several times... nothing.
Ensign
Join Date: Aug 2012
Posts: 3
# 10
10-22-2012, 06:27 AM
Cant claim it also. Logged in even on different languages and changed also instances..it worked for my both toons on FED-Side..but not on Klingon-Side..so what the hell is wrong?
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:34 PM.